题目描述:

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X – 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

输入:

Line 1: Two space-separated integers: N and K

输出:

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

输入样例:

5 17

输出样例:

4

注意!这题有个地方很坑,题目中没有说清楚有多组数据,实际上测试数据中是有多组数据的!要用while(cin>>n>>k) 输入!

题意:有一个农民和一头牛,他们在一个数轴上,牛在 k 位置保持不动,农户开始时在 n 位置。设农户当前在 M 位置,每次移动时有三种选择:1. 移动到 M-1;2. 移动到 M+1 位置;3. 移动到 M×2 的位置。问最少移动多少次可以移动到牛所在的位置。

思路:BFS,bool 数组判重,状态即为当前所在的坐标。
注意事项:判重数组要开 2 倍,即 2×10^5,不然可能会在做×2 的操作时数组越界!

代码:

#include <iostream>
#include <queue>
using namespace std;
int n,k;
bool book[200005];
queue<int> que,disque,cq;
int main()
{
    while(cin>>n>>k)
    {
        for(int i=0;i<200005;i++)book[i]=0;
        book[n]=1,que=disque=cq,que.push(n),disque.push(0);
        while(!que.empty())
        {
            if(que.front()==k){cout<<disque.front()<<endl;break;}
            if(que.front()>0)if(!book[que.front()-1])que.push(que.front()-1),disque.push(disque.front()+1),book[que.front()-1]=1;
            if(que.front()<k&&!book[que.front()+1])que.push(que.front()+1),disque.push(disque.front()+1),book[que.front()+1]=1;
            if(que.front()<k&&!book[que.front()<<1])que.push(que.front()<<1),disque.push(disque.front()+1),book[que.front()<<1]=1;
            que.pop(),disque.pop();
        }
    }
    return 0;
}

分类: 文章

XZYQvQ

炒鸡辣鸡的制杖蒟蒻一枚QvQ

0 条评论

发表回复

Avatar placeholder

您的电子邮箱地址不会被公开。 必填项已用 * 标注