题目

传送门= ̄ω ̄=

Problem

Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

  1. A is invertible.
  2. Ax = b has exactly one solution for every n × 1 matrix b.
  3. Ax = b is consistent for every n × 1 matrix b.
  4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:

  • One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
  • m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

Output

Per testcase:

  • One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

Sample Input

2
4 0
3 2
1 2
1 3

Sample Output

4
2

题解

题目真长,其实意思就是给你一个有向图,问你最少连多少条边才能使这个图只含一个强连通分量。
题目包含多组数据(输入的第一个整数表示数据组数)。

解法:强连通分量缩点,然后设出度为 0 的强连通分量有 ans1 个,入度为 0 的强连通分量有 ans2 个
则答案为:$ans=max(ans1,ans2)$

代码(kosaraju 算法):

#include <bits/stdc++.h>
using namespace std;
int t,n,m,cnt,scc[20005],ans1,ans2;
bool book[20005],out[20005],in[20005];
vector<int> g[2][20005];
stack<int> sta;
void initdfs(int u)
{
    book[u]=1;
    for(vector<int>::iterator i=g[0][u].begin();i!=g[0][u].end();i++)
        if(!book[*i])initdfs(*i);
    sta.push(u);
}
void dfs(int u)
{
    book[u]=1,scc[u]=cnt;
    for(vector<int>::iterator i=g[1][u].begin();i!=g[1][u].end();i++)
        if(!book[*i])dfs(*i);
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(book,0,sizeof(book)),memset(in,0,sizeof(in));
        memset(out,0,sizeof(out)),cnt=ans1=ans2=0;
        for(int i=1;i<=n;i++)g[0][i].clear(),g[1][i].clear();
        for(int i=1,a,b;i<=m;i++)
            scanf("%d%d",&a,&b),g[0][a].push_back(b),g[1][b].push_back(a);
        for(int i=1;i<=n;i++)if(!book[i])initdfs(i);
        memset(book,0,sizeof(book));
        while(!sta.empty())
        {
            int i=sta.top();sta.pop();
            if(!book[i])cnt++,dfs(i);
        }
        if(cnt==1){printf("0\n");continue;}
        for(int u=1;u<=n;u++)
            for(vector<int>::iterator i=g[0][u].begin();i!=g[0][u].end();i++)
                if(scc[u]!=scc[*i])out[scc[u]]=1,in[scc[*i]]=1;
        for(int i=1;i<=cnt;i++){if(!out[i])ans1++;if(!in[i])ans2++;}
        printf("%d\n",max(ans1,ans2));
    }
    return 0;
}
分类: 文章

XZYQvQ

炒鸡辣鸡的制杖蒟蒻一枚QvQ

0 条评论

发表回复

Avatar placeholder

您的电子邮箱地址不会被公开。 必填项已用 * 标注